python 环境下编程

确认开发目标

Pymycobot 是一个和 Mycobot 进行串口通讯的 python 包, 支持 Python2, Python3.5 及之后版本.

如果你想通过 Python 编程来控制 Mycobot,那么它是你的选择。

如何安装使用

在使用 pymycobot 之前请确保你已经拥有的 Mycobot 机械臂,并且做好了前置准备。

前置准备:

确保顶部的 Atom 烧入 Atom, 底部的 Basic 烧入 Transponder
The firmware Atom and Transponder download address: https://github.com/elephantrobotics/myCobot/tree/main/Software

Pip

pip install pymycobot --upgrade --user

Notes:

现在只支持 Atom2.4及之后版本. 如果你使用的之前版本, 请安装 pymycobot 1.0.7.

pip install pymycobot==1.0.7 --user

源码安装

git clone https://github.com/elephantrobotics/pymycobot.git <your-path>
cd <your-path>/pymycobot
# Install
python2 setup.py install
# or
python3 setup.py install

API 做为二级目录

如果你不想安装它,你可以使用它。 首先,你需要到项目的 github 中将其下载到本地。

项目地址:https://github.com/elephantrobotics/pymycobot

然后,将项目中的 pymycobot 文件放入你的项目之用,你就可以直接导入使用。

results matching ""

    No results matching ""